DBM fails to run bot after inserting commands via Raw Data, old save still runs.

Discussion in 'Bug Reports' started by Generel Schwerz, Jun 2, 2019.

  1. Generel Schwerz

    Generel Schwerz New Member

    Joined:
    May 2, 2019
    Messages:
    2
    Likes Received:
    0
    I've been experiencing some issues with DBM's "edit Raw Data" commands and it is somewhat infuriating. About a month ago, a bot that worked fine suddenly stopped opening. I am now unable to run the bot. From what I've been able to discover, either a mistranslation in Raw Data is stopping the bot from even attempting to run (unlikely) or bots have some kind of maximum command limit.

    This is the bot's command list: [​IMG]
    https://gyazo.com/cf9062d35959be44170c8e7b17ad62f6
    (there were more but even after cutting down the bot refuses to run)

    By refusing to run I mean the bot never starts.
    The save option never appears: (https://gyazo.com/a601a442456e47d0b4df9e0715cdf07a)
    Nothing appears in the bot log: (https://gyazo.com/3faa49afc852cf5aa3880cbd2191a97e)

    I reset the bot to an earlier version with two commands and it worked fine. However, when inputting these commands the bot stops trying to run. I have attempted multiple fixes for this to work.

    Attempted solutions:
    1. Check each command to see if they run if they are the only command. (Success)
    2. Paste Raw Data from the original bot and copy it to another to check if there was a file issue (Failure, same as before)
    3. Went to commands.json file under data and copied everything over. (Failure, same as before)
    4. Rewrote every command. (Failure, same as before)

    All other bots work fine. I have no issues with any other bots, only this one. If was some kind of maximum command limit that I am unaware of that was implemented into Beta... welp. :/
     
    #1 Generel Schwerz, Jun 2, 2019
    Last edited: Jun 12, 2019 at 1:53 PM

Share This Page